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Overview
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De-compositional analysis of a channel with AC 
decoupling capacitors
Constructing internal ports to connect lumped or 
distributed components
Validation of internal port model with experimental data
Building models for AC capacitor mounting structures for 
a single-ended channel
Building models for AC capacitor mounting structures for 
a differential channel
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Introduction
Serial multi-gigabit data channels usually have capacitors connected 
in series either in single-ended micro-strip or differential micro-strip 
lines to pass through the high-frequency signals content and to allow 
different DC supply for a driver and receiver at the same time

Such capacitors are often called AC coupling capacitors
Mounting structures of such capacitor and capacitors themselves are 
discontinuities and have to be accounted for in a system-level analysis 
Accurate models for the AC coupling capacitor mounting structures can 
be built with a 3-D full-wave electromagnetic solver

This example demonstrates how to build 3D full-wave models for the 
AC coupling capacitor mounting structures and how to build a 
system-level model of a simple channel with AC coupling capacitors
Simbeor 2007 electromagnetic solver from Simberian Inc. and 
HyperLynx+Eldo system-level solver from Mentor Graphics are used 
to generate the results



De-compositional analysis of a serial multi-
gigabit channel with AC coupling capacitors
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Decomposition

Attenuation and dispersion 
in transmission lines

Reflection from AC capacitors 
and mounting structures

W-element models for t-line 
segments defined with 
RLGC(f) p.u.l. tables

Multiport S-parameter 
model for the capacitors 

mounting structures

3-D full-wave electromagnetic 
analysis is required to generate 
models both for the mounting 
structure and transmission lines!

We will use Simbeor to do it.

Capacitor model from a 
manufacturer (circuits 

or S-parameters)

The same approach 
for single and 
differential channels



Internal port concept
Internal or lumped ports can be constructed and used to connect models of 
the capacitors or other components with external models
Before investigating the capacitors mounting structures, we construct and 
investigate behavior of the internal ports

Solution LumpedPorts.esx created to do this investigation (link to the file with all zipped 
solutions is on the last page)
Micro-strip line with 8-mil wide strip on 4.5 mil substrate with DK=4.2 and LT=0.02 are used 
for all experiments with the internal ports
We construct a set of structures with different internal ports and perform numerical 
experiments with predictable results such as shown below:
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T-line 
port 1

T-line 
port 2

Series internal 
port

T-line 
port 1

T-line 
port 2

Short-circuited 
internal port

Parameters of such structure should be 
similar to simple line segment



Series internal ports (SeriesPortSmall)
Connected into a strip-line in series
Ports can be as small as possible (down to 1 cell along the port) or 
correspond to a footprint of a lumped component to be connected
The results of analysis are S-parameters of 3-port multiport
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60 mil distance between 
the phase reference 
planes of t-line inputs

Internal X-Port
Port is 20cell long to 
preserve the symmetry



Parallel internal ports (ParallelPorts)
Connected at the ends of strip-line in parallel
One of the sizes of the port can correspond to actual lumped device 
size another is as small as possible on the grid
Ports span between the strip line and the reference plane or strip
The results of analysis are S-parameters of 4-port multiport
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60 mil distance between 
the phase reference 
planes of t-line inputs

Internal Z-Ports in a 
20-mil gap



60-mil micro-strip line segment for 
comparison (ShortCircuit)

Micro-strip line with 8-mil wide strip on 4.5 mil substrate with DK=4.2 
and LT=0.02 are used for all experiments with the internal ports
The results of analysis are 2-port S-parameters with automatically 
de-embedded transmission line inputs with phase reference planes 
shifted to have 60 mil segment in the middle
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Reflection because of 
Zo of line is not 
exactly 50 Ohm 



Through calibration of the ports with 10-ps 
step response
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Responses of all 
structures are in 
good agreement 
as expected

Simbeor models used in HyperLynx 7.7 with 
Eldo for the analysis 60-mil micro-strip 

line segment

Structure with series 
port short-circuited by 
0.1 mOhm resistor

Structure with two 
parallel ports 
connected to 20-mil 
line segment to fill 
the gap

T[2,1]

T[1,1]



Validation of the internal port models
For validation of the internal port models we can use structure with thick film chip 
resistor connected in series into micro strip line and investigated numerically and 
experimentally in 

Y. C. Lau, M. S. Leong, and P. S. Kooi, “Modeling of chip resistors for high-frequency 
microwave applications with the use of the FDTD method,” Microwave Opt. Technol. Lett., 
vol. 14, no. 5, pp. 259–261, Apr. 1997.
R. Gillard, S. Dauguet, and J. Citerne, “Correction Procedures for the Numerical Parasitic 
Elements Associated with Lumped Elements in Global Electromagnetic Simulators”, IEEE 
Trans. on MTT, v. 46, N9, 1998, p. 1298-1306.
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Studied structure. (a) The loaded microstrip line (a = 
6.578 mm, b = 3.048 mm, c = 55.653 mm, DK= 2.2, h = 
0.508 mm, w = 1.518 mm).

(b) The thick-film chip resistor (WR = 1.214 
mm, HR = 0.508 mm, LR = 4.047 mm).

Lumped resistor model



Electromagnetic model with series port
Simbeor solution PortsBenchmark.esx, circuit SeriesPort
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Series port instead of resistor

3-port model is created 
with transmission line 
ports 1 and 2 and internal 
port 3



Electromagnetic model with parallel ports
Simbeor solution PortsBenchmark.esx, circuit ParallelPorts
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Two parallel ports instead of resistor

4-port model is created 
with transmission line 
ports 1 and 2 and internal 
ports 3 and 4



10-Ohm resistor in micro-strip line
Good correspondence of data computed by 3 different methods and experiment from 
[7] up to 10 GHz (the structure is electrically oversized above 10 GHz and lumped 
model becomes inaccurate in this case)
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Graph from R. Gillard, S. Dauguet, and J. Citerne, 
IEEE on MTT, N9, p. 1302
[7] is paper of Y. C. Lau, M. S. Leong, and P. S. Kooi

Exact resistor model 
connected to parallel ports 
(R=10)

Resistor model with 
inductance reduced to 
150 pH connected to 
the series port (R=10)



Materials and stack-up for analysis of the 
capacitors mounting structures

Solution CapsMounting.esx created for this investigation (link to the file with 
all zipped solutions is on the last page)
Simple 4-layer stackup with two signal layers and two plane layers
Stackup is extended to simulate connection of the capacitor slightly above 
the board surface
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Wideband Debye model for 
FR-4 type dielectric

Thin layer of air and additional layer 
“CapPlane” of signal-type are added to 
simulate non-flat connection of the capacitors

Use Help > Tutorials > Tutorial 1 to 
learn how to build models for 
materials and stackup 



Single-ended channel – transmission line 
(circuit SingleMSL)

8 mil wide strip on 4.5 mil substrate with Dk=4.2, 
LT=0.02 at 1 GHz and wideband Debye dielectric model
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Use Help > Tutorials > Tutorial 2 to learn 
how to build broadband RLGC(f) models 
for transmission line 



Short-circuit experiment with 0402 capacitor 
footprint (ShortCircuitedSingle)

Capacitor in micro-strip line with 8 mil wide trace
Allows us to estimate of the minimal possible reflection
May be used to do the through calibration of the internal ports
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Simulation from 10 MHz to 50 GHz

Reflection loss is 
above -20 dB at 4.5 
GHz

20x20 mil pads in 
layer “Signal1” 

40x20 mil short-circuiting 
plate is slightly elevated 
above the board surface 
(layer “CapPlane”)

Phase reference 
planes shifted to 
the pads



Short-circuit experiment with 0603 capacitor 
footprint (SCSingle0603)

The larger the footprint the larger the minimal possible reflection loss 
Impedance of the actual capacitor will make reflection worse at most of the 
frequency band
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Simulation from 10 MHz to 50 GHz

Reflection loss is 
above -20 dB at 
1.1 GHz !

20x60 mil pads in 
layer “Signal1” 

30x60 mil short-circuiting 
plate is slightly elevated 
above the board surface 
(layer “CapPlane”)

Phase reference 
planes shifted to 
the pads



TDR and TDT of the short-circuited 
footprints of the capacitors

Short-circuit is an “ideal” capacitor – the reflection is the minimal possible
Even in that case the discontinuity in the transmission line is clearly visible 
in time-domain and may be serious problem in a complicated channel
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Simbeor models used in HyperLynx 7.7 with Eldo for the analysis

T[2,1]

T[1,1]

T[2,1]

T[1,1]



Series internal port to connect 0402 
capacitor (SeriesPortSingle)

May be used if capacitor model extracted by comparison with the short-
circuited pads (usually leads to lower estimated ESL of the capacitor)
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Component input with X-directed 
port (X-Port port 3) in the 
middle of the plate connecting 
two pads

3-port broad-band S-parameter model of 
the mounting structure exported from 
Simbeor in Touchstone format

Transmission line inputs (ports 1 
and 2) with reference planes 
shifted toward the pads



Parallel internal ports to connect 0402 
capacitor (ParallelPortsSingle)

May be used if capacitor model extracted by comparison with the open-
circuited pads (usually leads to complex model with higher ESL and 
substantial delay in the capacitor model)
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Component input with 2 Z-
directed ports (Z-Ports: port 3 
and 4) at the edges of the pads

4-port broad-band S-parameter model of the mounting 
structure is exported from Simbeor in Touchstone format

Transmission line inputs (ports 1 
and 2) with reference planes 
shifted toward the pads



Through calibration of the 0402 capacitor 
ports with 10-ps step response
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Responses of all 
structures are in 
good agreement 
as expected

Simbeor models are used in HyperLynx+Eldo 
for the analysis

Short-circuited pads

Structure with the series 
port short-circuited by 
0.1 mOhm resistor

Structure with two 
parallel ports 
connected to 20-mil 
line segment to fill the 
gap

T[2,1]

T[1,1]



AC coupling capacitor in a simple single-
ended channel

10.65 cm long channel is simulated with and without the mounting structure
Simbeor is used to generate models for both t-lines and mounting structure and 
HyperLynx+Eldo is used for analysis of the complete channel
100 nF capacitor has 100 pH added ESL and 1 mOhm ESR

10/7/2008 © 2008 Simberian Inc. 22

Model with the 
mounting 
structure

T[1,1] T[2,1]

Model without the 
mounting structure with 
the capacitor model 
connected directly in the 
channel

J9 and J13 are 5 mm t-line segments
J12 is 10.15 cm and J6 is 10 cm t-line 
segment. All are W-elements defined 
with RLGC(f) extracted with Simbeor



AC coupling capacitor in a simple single-
ended channel

10.65 cm long channel with AC capacitor close either to driver or to receiver is simulated
Simbeor is used to generate models for both t-lines and mounting structure and HyperLynx+Eldo is 
used for analysis of the complete channel
100 nF capacitor has 100 pH added ESL and 1 mOhm ESR
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Reflection in case of 
capacitor near the 
driver

J6 and J8 are 10.15 cm t-line segments
J9 and J10 are 5 mm t-line segment. All are W-elements 
defined with RLGC(f) extracted with Simbeor

Reflection in case 
of capacitor near 
the receiver

Capacitor near the 
driver

Capacitor near the 
receiver



Eye-diagram for the simple channel with AC 
coupling capacitor and 20 Gb/s signal
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Structure with 0603 
capacitor (circuit 
SPSingle0603)

Structure with 
0402 capacitor

10.65 cm long channel with AC capacitor close to driver, 100 nF capacitor has 100 pH 
added ESL and 1 mOhm ESR



Differential channel – transmission line 
(circuit CoupledMSL)

Two 7 mil wide strips with 17 mil distance between 
centers on 4.5 mil substrate with Dk=4.2 and LT=0.02
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Use Help > Tutorials > Tutorial 2 to learn 
how to build broadband RLGC(f) models 
for differential transmission lines



Short-circuit experiment at 0603 capacitor 
footprint (SCSingle0603)

Investigation of the minimal possible reflection of the differential mode
Mixed-mode S-parameters plotted to investigate the reflection (see more on S-
parameters conversion and plotting in Help > Manual > Mixed-mode scattering 
parameters)
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Simulation from 10 MHz to 50 GHz

Reflection loss is above 
-20 dB at 4 GHz

20x60 mil pads in 
layer “Signal1” 

30x60 mil short-circuiting 
plates are slightly elevated 
above the board surface 
(layer “CapPlane”)

Phase reference planes 
of t-line inputs shifted 
toward the pads

Multiport parameters profile has to be adjusted to see the 
mixed-mode S-parameters on the graph (Simulation > Results 
> Multiport Parameters > Set New Profile > Input Space > 
Mixed Mode)



Series internal ports to connect two 0402 
capacitors (circuit SeriesPorts)

May be used if capacitor model extracted by comparison with the short-
circuited pads (usually leads to lower estimated ESL of the capacitor)
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Two component inputs with X-directed 
port (X-Port, ports 5 and 6) in the 
middle of the plate connecting two pads

6-port broad-band S-parameter model of 
the mounting structure exported from 
Simbeor in Touchstone format

Coupled transmission line inputs 
(ports 1, 2 on one side and 3,4 
on the other) with reference 
planes shifted toward the pads



Parallel internal ports to connect two 0402 
capacitors (circuit ParallelPorts)

May be used if capacitor model extracted by comparison with the open-
circuited pads (usually leads to complex model with higher ESL and 
substantial delay in the capacitor model)
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Component inputs with 2 Z-directed ports 
each (Input 3 - ports 5 and 6, Input 4 –
ports 7 and 8) at the edges of the pads

8-port broad-band S-parameter model of the 
mounting structure exported from Simbeor in 
Touchstone format

Coupled transmission line inputs 
(ports 1,2 and 3,4) with reference 
planes shifted toward the pads



Through calibration of the 0402 capacitor 
ports with 10-ps step response
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Responses of all 
structures are in 
good agreement 
as expected

Simbeor models are used in HyperLynx+Eldo 
for the analysis Short-circuited pads

Structure with 2 series 
ports short-circuited by 
0.1 mOhm resistors

Structure with 4 parallel 
ports connected to two 
15-mil line segments to 
fill the gap

T[2,1]

T[1,1]



AC coupling capacitor in a simple differential 
channel

10.65 cm long channel is simulated with and without the mounting structure
Simbeor is used to generate models both for t-lines and mounting structure and 
HyperLynx+Eldo is used for analysis of the complete channel
100 nF capacitor has 100 pH added ESL and 1 mOhm ESR
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Model with the 
mounting 
structure

T[1,1] T[2,1]

Model without the 
mounting

J6 and J14 are 5 mm coupled t-line segments. 
J15 is 10.15 cm and J7 is 10 cm coupled t-line 
segments. All are W-elements defined with 
RLGC(f) extracted with Simbeor.



More numerical experiments…
HyperLynx file AC_CouplingCapacitors.ffs set up to 
investigate TDR and TDT of differential channel with 
capacitor connected closer to driver and receiver
HyperLynx file AC_CouplingCapacitors20Gbps.ffs set up 
to investigate propagation of 20 Gb/s signal in a 
differential channel with the AC coupling capacitors
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Conclusion
Simple examples of Simbeor application for extraction of 
electromagnetic models of capacitor mounting structure are 
provided
The effect of the mounting structures for 0402 capacitors is minor, 
though larger footprints like 0603 cause visible degradation of multi-
gigabit signal even in a simple channel without other discontinuities

The problem may be more visible in case if there are some via-holes in the 
channel and interactions between multiple discontinuities produce resonances at 
some critical frequencies 

Electromagnetic models of the mounting structures can be used
For accurate modeling of multi-gigabit serial data channels 
For identification of the models for the capacitors by comparison of 
simulation and measurement results

Setting up all simulations and model building with Simbeor took 
approximately 2 hours



Solutions and contact
Simbeor solution files and HyperLynx schematic 
files are available for download from the 
simberian web site

http://www.simberian.com/AppNotes/Solutions/AC_CouplingCapacitors_2008_02.zip

Send questions and comments to
General: info@simberian.com
Sales: sales@simberian.com
Support: support@simberian.com

Web site www.simberian.com
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